Welcome to GemLou.pe!

View the full dependency tree for any ruby gem.

Avoid bloat! Keep that Gemfile slim.

See how many dependencies a gem has *before* adding it to your project.

Get started now!

GemLou.pe Inspector

  1. Drag this button to your bookmark bar.
  2. Find a gem on RubyGems.org or Ruby-Toolbox.com.
  3. Click the bookmark, to see the dependencies for that gem.
  4. On other sites you can click the bookmark and enter the name of the gem you want to look up.

Here's a sample report:


devise 2.2.3

Weight: 23 gems

devise 2.2.3 (req 2.2.3)
railties 3.2.13 (req ~> 3.1)
actionpack 3.2.13 (req = 3.2.13)
erubis 2.7.0 (req ~> 2.7.0)
sprockets 2.2.2 (req ~> 2.2.1)
tilt 1.3.6 (req != 1.3.0, ~> 1.1)
rack 1.4.5 (req ~> 1.0)
multi_json 1.7.2 (req ~> 1.0)
hike 1.2.1 (req ~> 1.2)
journey 1.0.4 (req ~> 1.0.4)
rack-test 0.6.2 (req ~> 0.6.1)
builder 3.0.4 (req ~> 3.0.0)
rack-cache 1.2 (req ~> 1.2)
activemodel 3.2.13 (req = 3.2.13)
activesupport 3.2.13 (req = 3.2.13)
i18n 0.6.1 (req = 0.6.1)
rdoc 3.12.2 (req ~> 3.4)
json 1.7.7 (req ~> 1.4)
thor 0.18.0 (req < 2.0, >= 0.14.6)
rack-ssl 1.3.3 (req ~> 1.3.2)
rake 10.0.4 (req >= 0.8.7)
bcrypt-ruby 3.0.1 (req ~> 3.0)
orm_adapter 0.4.0 (req ~> 0.1)
warden 1.2.1 (req ~> 1.2.1)

Action shot!

Rubygems-screenshot